Downloads Resources over HTTP

Module: kindlegen

Published: December 16th, 2016

Reported by: Adam Baldwin

CVE-NONE

CWE-818

Vulnerable: <1.1.0
Patched: >=1.1.0

Overview

Affected versions of kindlegen insecurely download an executable over an unencrypted HTTP connection.

In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running kindlegen.

Remediation

Update to version 1.1.0 or greater.