Regular Expression Denial of Service

Module: charset

Published: September 8th, 2017

Reported by: Cristian-Alexandru Staicu

CVE-NONE

CWE-400

Vulnerable: <1.0.0
Patched: >=1.0.1

Overview

Affected versions of charset are susceptible to a regular expression denial of service.

The amplification on this vulnerability is relatively low - it takes around 2 seconds for the engine to execute on a malicious input which is 50,000 characters in length.

If node was compiled using the -DHTTP_MAX_HEADER_SIZE however, the impact of the vulnerability can be significant, as the primary limitation for the vulnerability is the default max HTTP header length in node.

Remediation

Update to version 1.0.1 or later.

References

Issue #10